Skip to content

Kdenlive installation

Install kdenlive on Linux Mint

It is recommended to download the AppImage version until at least version 5.11 of Qt was include into Ubuntu.

More detail on Kdenlive release repository

Current stable AppImage (19.04.3) is available here. To install, just download the file and make it executable.

Here is a script to download, install and create menu entry for kdenlive. .

If you dont want to download this script, you can run:

curl -s https://git.cclaude.rocks/install/kdenlive-install/raw/master/kdenlive-install.sh | bash